Some users can experience the security error when trying to follow a short URL. The reason is that Short.io uses the TLS 1.2 and TLS 1.3 encryption standard, and old browser versions don't support them.

What versions do not support TLS 1.2 and TLS 1.3?

  • IE8-10
  • iOS Safari < 4.3
  • mobile Firefox < 26
  • mobile Chrome < 28

Detailed about supported versions: https://caniuse.com/#feat=tls1-2

How to enable TLS 1.2 in Internet Explorer

If you use Internet Explorer, then follow the steps to make your browser compatible with TLS 1.2. To change the settings in IE 8, 9 or 10:

  • Go to Tools and select Internet Options
  • Select the Advanced tab in Internet Options
  • Enable (check) TLS 1.2 and also disable (uncheck) SSL 3.0 for additional security
  • Click on Apply and OK to complete the procedure

Source: https://support.freshdesk.com/

Did this answer your question?